Bug #1087

Sprachumschaltung auf lib1-Seiten funktioniert nicht mehr

Von following vor mehr als 1 Jahr hinzugefügt. Vor mehr als 1 Jahr aktualisiert.

Status:erledigt% erledigt:

100%

Priorität:2 mittel
Zugewiesen an:teiling88
Zielversion:Version 3.1.4
Ticket Referenz: Kategorien:

Beschreibung

Das Umschalten der Sprache funktioniert auf den Seiten newcache.php, editcache.php etc nicht mehr.

Habe geprüft ob es mit meinem Fix für #1080 zusammenhängt. Das Problem bestand auch schon vorher, hat sich allerdings verschlimmert: Vorer passierte einfach gar nichts, nun wird eine nicht vorhandene Seite aufgerufen.

Zugehörige Revisionen

Revision 998644cd
Von teiling88 vor mehr als 1 Jahr hinzugefügt

bugfix for language switch
fixes #1087

Historie

#1 Von teiling88 vor mehr als 1 Jahr aktualisiert

  • Zugewiesen an wurde auf teiling88 gesetzt

#2 Von teiling88 vor mehr als 1 Jahr aktualisiert

  • Zielversion wurde auf Version 3.1.4 gesetzt

#3 Von teiling88 vor mehr als 1 Jahr aktualisiert

  • Status wurde von neu zu in Arbeit 50% geändert
  • Priorität wurde von 3 hoch zu 2 mittel geändert
  • % erledigt wurde von 0 zu 50 geändert

Er wechselt zwar nicht die Sprache bleibt aber auf der Seite. Quasi der alte Zustand wiederhergestellt.

#4 Von teiling88 vor mehr als 1 Jahr aktualisiert

  • Status wurde von in Arbeit 50% zu erledigt geändert
  • % erledigt wurde von 50 zu 100 geändert

Gefixed und live genommen.

#5 Von following vor mehr als 1 Jahr aktualisiert

  • Status wurde von erledigt zu in Arbeit geändert
  • % erledigt wurde von 100 zu 0 geändert

Die lib1-Spracheinstellung funktioniert immer noch nicht richtig. Beispiel:

1. Startseite aufrufen https://www.opencaching.de
1. auf Englisch umschalten: https://www.opencaching.de/?locale=EN
2. neuen Cache eintragen: https://www.opencaching.de/newcache.php
3. auf Deutsch umschalten: https://www.opencaching.de/newcache.php?locale=DE
4. irgendwas anderes machen, z.B. die Startseite aufrufen

=> Sprache ist Englisch, sollte aber Deutsch sein

#6 Von following vor mehr als 1 Jahr aktualisiert

("erledigt 0%" hat Redmine gesetzt, ich konnte nur "in Arbeit" wählen)

#7 Von teiling88 vor mehr als 1 Jahr aktualisiert

  • Status wurde von in Arbeit zu in Arbeit 50% geändert
  • % erledigt wurde von 0 zu 50 geändert

#8 Von teiling88 vor mehr als 1 Jahr aktualisiert

  • Status wurde von in Arbeit 50% zu im Test geändert
  • % erledigt wurde von 50 zu 90 geändert

#9 Von teiling88 vor mehr als 1 Jahr aktualisiert

  • Status wurde von im Test zu erledigt geändert
  • % erledigt wurde von 90 zu 100 geändert

Status geändert durch Changeset oc-server3|998644cdd5873fa5857af27c021893e887c1ff94.

Auch abrufbar als: Atom PDF