Bug #1163

Benutzer-Logindatum nicht aktualisiert?

Von following vor mehr als 1 Jahr hinzugefügt. Vor mehr als 1 Jahr aktualisiert.

Status:erledigt% erledigt:

100%

Priorität:2 mittel
Zugewiesen an:following
Zielversion:Version 3.1.5
Ticket Referenz: Kategorien:profil

Beschreibung

Hier gibt es zwei auf den 5. August 2017 datierte Logs des Owners, aber im Admin-Interface wird für diesen Benutzer "Letzter bekannter Login: 01.08.2017" angezeigt.

Entweder wurden die Logs mit falschem Datum eingestellt (da müsste mal jemand mit Serverzugang nachschauen), oder es gibt einen Bug in der Session-Verwaltung.

Prio 3, weil dieses Datum wichtig ist für die Supportarbeit.

Historie

#1 Von following vor mehr als 1 Jahr aktualisiert

da müsste mal jemand mit Serverzugang nachschauen

Notfalls kann ich das auch per XML-Interface machen, ist aber 100mal aufwändiger.

#2 Von teiling88 vor mehr als 1 Jahr aktualisiert

  • Status wurde von neu zu Feedback geändert
  • Zugewiesen an wurde auf following gesetzt
  • Priorität wurde von 3 hoch zu 2 mittel geändert

Laut Datenbank ist der Benutzer am 2017-08-06 letzten mal eingeloggt gewesen.

#3 Von teiling88 vor mehr als 1 Jahr aktualisiert

Ich hab nicht lange geschaut aber in der adminuser.php wird das letzte Login Datum so ermittelt:

SELECT MAX FROM `sys_sessions` WHERE `user_id`='&1'

Die Okapi aber schreibt in das last_login Attribut von user. Kann das die Ursache sein?

#4 Von following vor mehr als 1 Jahr aktualisiert

  • Status wurde von Feedback zu in Arbeit geändert
  • Zielversion wurde auf Version 3.1.5 gesetzt

Mit der OKAPI kann man keinen Cachestatus loggen, d.h. der Benutzer muss am 6. August per www.opencaching.de angemeldet gewesen sein.

#5 Von teiling88 vor mehr als 1 Jahr aktualisiert

In der s_user steht bei last_login: 2017-08-06

#6 Von teiling88 vor mehr als 1 Jahr aktualisiert

  • Status wurde von in Arbeit zu Feedback geändert

#7 Von following vor mehr als 1 Jahr aktualisiert

  • Status wurde von Feedback zu im Test geändert
  • % erledigt wurde von 0 zu 90 geändert

Bugfix liegt auf Github.

#8 Von teiling88 vor mehr als 1 Jahr aktualisiert

  • Status wurde von im Test zu erledigt geändert
  • % erledigt wurde von 90 zu 100 geändert

Auch abrufbar als: Atom PDF